Device is locked by other application or disabled

Music Production Forums General Section Device is locked by other application or disabled


Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
  • #18009

    Hey all, I’m using Windows 10 and can’t set up my interface with SoundBridge, as it thinks that something’s using my interface (Focusrite Scarlett 2i2). Even when I don’t have a single other program or sound settings open.

    I’ve tried toggling exclusive control on both the line in and line out in Windows 10’s horrific audio settings. Every other audio program outputs sound just fine in turn when I try them.

    These are my audio settings in SoundBridge:

    If somebody could please lend some useful advice, then I’ll be able to use this program in good faith and give it an honest go before deciding what I think about it. I do want to donate to the project if I get some use out of it–all I’m trying to do a at the moment is try a new bass through a VST and I can’t even do that.

    Cheers guys.



    Please try using an ASIO driver that Scarlet provides, not MME. I think this will solve your problem.



    I am not currently only working on my laptop with the inbuilt soundcard and also having this issue. Any advice would be great?



    Try changing the audio driver, that would be the best solution. Try changing to WASAPI if ASIO is unavailable, or download ASIO4ALL driver from the internet.


    i have the same issue too. After downloading ASIO4ALL, my Soundbridge crashed everytime I open it. Can’t solve the issue, anyone has other suggestions? My default speaker is Realtek. Tried changing to Windows output, but still does not work. Pls help, thank you.



    If you are experiencing a crash on startup follow the steps in our “Experiencing a crash on startup?” FAQ article.
    Find it here:


    Hey, I have the problem, anyone can help me how to solve this?


    I am having a similar problem, I get the ASIO4ALL set up no problem…I tested all the Windows 10 MME and WASAPI works fine, ASIO sets up okay, when i record an audio track, i have latency issues, garbled drop out distorted audio mic levels are unity…then i go back to change an option and bye bye crash… and then a launch again and its confused about last project… I reinstalled it all, i used Revo unistaller to get all the files out … this happens every time i reinstall and test the ASIO4ALL… 6 hours in,,, sleepy time… good luck!


    If you go into your Windows registry you could make a mistake… your system could be toast use this free download its works great and takes all the supporting junk away for a clean install.. if your techie modify the reg in Windows like the faq discribes lol


    Oh my how did you get the sample rate at 44.1k in the diagram???????… I can only adjust 48k, 96k and 192k interesting…


    Anyone have issues with Master Clock changing audio drivers > Revert to 48khz?


    Please try this:
    1. Open Control Panel.
    2. In the Control Panel open “Sound”.
    3. In the “Playback” tab select your default used playback device and open its Properties.
    4. In the Advanced tab of the Properties uncheck/disable the “Allow applications to take exclusive control of this device”.

    Alternatively you can try to change between the drivers you are using (ASIO, MME, DirectX and WASAPI).


    I ended up removing the drivers> and Re-Installing them> and chose to remove an automatic console changer feature upon install.

    It does not change clock freq any more>

    Thank you for the instructions.


    Please unlocked my device


    I have Presonus Studio 24c interface with Studio USB ASIO Driver, and the app says “Device is locked by other application or disabled.”
    Any other DAW I have tried or is installed on my computer works without problems, but not Soundbridge. Could you please look into it?

Viewing 15 posts - 1 through 15 (of 20 total)
  • You must be logged in to reply to this topic.