RitMix auth req. upon re-open

Music Production Forums General Section RitMix auth req. upon re-open

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #42468


    During a previous session, I added a RitMix designated MIDI track to my arrangement to add an extra kick to an Audio track. In my current session, I noticed that the extra kick was missing. While the arrangement was playing, I opened RitMix. As soon as I logged in, the MIDI track started producing the kicks. Is re-authorization per session a designed requirement for projects with RitMix integration?

    Perhaps there is a way to notify the user upon opening a project session with RitMix integration that re-authorization is required. Either as a simple dialog box with instructions or a small modal window with an Authorization button that ?shadow? links to the Show Plugin functionality on the first RitMix assigned MIDI track. In theory, this shouldn’t require any code changes in RitMix. SoundBridge would have to parse a project, looking for an instance of RitMix before sending a re-auth request. This only needs to happen if RitMix is present.

    Does reChord operate in the same way? If yes & RitMix is also present, 3 auth requests at the beginning of a project session may be a bit much. Especially if authentication is sandboxed to each project independently for the current session. 2 projects = 2 times the fun, etc.

    I actually consider myself lucky in that the arrangement was playing when I opened RitMix. Otherwise I wouldn’t have known that the MIDI track was back and would have rebuilt it only to get lost on the next session.



    Thank you for reaching out and using SoundBridge.

    Usually, RitMix only asks for authentication once in 30 days.

    But very rarely, for random reasons, RitMix has to reconnect to the server, and you have to re-login.

    How often do you experience this?

    It may also help to change your DNS server settings to 8 . 8 . 8 . 8
    dns settings
    On Windows, go to Settings => Network and Internet => Change adapter options => Properties => Internet Protocol Version 4

    The SoundBridge team.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.